RFR: 8265244: Remove useless comparation in LibraryCallKit::inline_vector_convert() [v2]
whuang at openjdk.java.net
Fri Apr 30 02:26:53 UTC 2021
On Thu, 29 Apr 2021 15:06:15 GMT, Andrew Haley <aph at openjdk.org> wrote:
> Please change the title of this to
> 8265244: AArch64: Remove useless comparation in LibraryCallKit::inline_vector_convert()
> since it affects the AArch64 port. This makes the logs and the mailing lists much easier to read.
Thank you for your suggestion. There is only one question here:
int num_elem_for_cast = MIN2(num_elem_from, Matcher::max_vector_size(elem_bt_to));
which will be removed here can effect all cpus.
More information about the hotspot-compiler-dev