RFR: 8003310: Enable -Wunused when compiling with GCC
Vladimir.Kozlov at oracle.com
Tue Nov 13 10:02:52 PST 2012
In opto/subnode.cpp leave the beginning of commented code to explain why
we don't do such optimizations.
On 11/12/12 19:59, Mikael Vidstedt wrote:
> Please review the below change. The change adds the -Wunused flag when
> compiling with GCC and removes a number of unused functions/dead code.
> In the process I found one function (same_page) which was duplicated in
> four different places. I merged it to a single function, renamed it to
> clamp_address_in_page, added some comments and refactored it to be
> slightly easier to understand. I also added unit tests for it. Feedback
> appreciated (especially on the name).
> Passes JPRT and the built-in unit tests (-XX:+ExecuteInternalVMTests).
More information about the hotspot-dev