RFR: 8230877: Rename THREAD_LOCAL_DECL to thread_local

Per Liden per.liden at oracle.com
Thu Sep 12 11:42:43 UTC 2019

On 9/12/19 12:53 PM, David Holmes wrote:
[...]>> So, how about I dial this back a bit, and just rename
>> THREAD_LOCAL_DECL to THREAD_LOCAL, just to make it a bit less clunky? 
>> That doesn't give us all the benefits I originally had in mind, but 
>> given the constraints we have here I don't see any better alternatives.
>> Updated webrev: http://cr.openjdk.java.net/~pliden/8230877/webrev.2
> The rename to drop _DECL is fine and trivial.
> Removing the USE_LIBRARY_BASED_TLS_ONLY guard makes it harder to test 
> with compiler-thread-local disabled. But not drastically so.
> So I'm okay with this minor change.

Thanks David!


More information about the hotspot-dev mailing list