RFR: 8230877: Rename THREAD_LOCAL_DECL to thread_local

Kim Barrett kim.barrett at oracle.com
Thu Sep 12 17:21:08 UTC 2019

> On Sep 12, 2019, at 4:48 AM, Per Liden <per.liden at oracle.com> wrote:
> So, how about I dial this back a bit, and just rename THREAD_LOCAL_DECL to THREAD_LOCAL, just to make it a bit less clunky? That doesn't give us all the benefits I originally had in mind, but given the constraints we have here I don't see any better alternatives.
> Updated webrev: http://cr.openjdk.java.net/~pliden/8230877/webrev.2
> /Per

That looks good.

Too bad the earlier version didn’t work out; it looked nice.

More information about the hotspot-dev mailing list