request for review (m) - 7121618

Jon Masamitsu jon.masamitsu at
Tue Dec 20 18:34:07 UTC 2011

I've updated the webrev for review comments
(thanks, Bengt).

On 12/19/11 11:33, Jon Masamitsu wrote:
> This changes the type used for the number of GC threads to unsigned 
> int from
> mostly size_t and changes corresponding variables that take the number 
> of GC
> threads also to unsigned int.  Some variables names were also changed in
> the process (principally "int i" in the work() method where "i" refers to
> the thread to "uint worker_id").
> There are many changes but all are straightforward type or
> name changes.
> 7121618: Change type of number of GC workers to unsigned int.
> Thanks.

More information about the hotspot-gc-dev mailing list