request for review (m) - 7121618

Srinivas Ramakrishna ysr1729 at gmail.com
Wed Dec 21 06:46:42 UTC 2011


Hi Jon --

I probably won't have the time to look at the specific changes but I'm so
happy to
see those int's change to unit's. This has been a wart that needed fixing
for a long time,
and I am glad you are cleaning this up. So my "+1" for this change!! :-)

-- ramki

On Mon, Dec 19, 2011 at 11:33 AM, Jon Masamitsu <jon.masamitsu at oracle.com>wrote:

> This changes the type used for the number of GC threads to unsigned int
> from
> mostly size_t and changes corresponding variables that take the number of
> GC
> threads also to unsigned int.  Some variables names were also changed in
> the process (principally "int i" in the work() method where "i" refers to
> the thread to "uint worker_id").
>
> There are many changes but all are straightforward type or
> name changes.
>
> 7121618: Change type of number of GC workers to unsigned int.
>
> http://cr.openjdk.java.net/~**jmasa/7121618/webrev.00/<http://cr.openjdk.java.net/%7Ejmasa/7121618/webrev.00/>
>
> Thanks.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.openjdk.java.net/pipermail/hotspot-gc-dev/attachments/20111220/473ecdb1/attachment.htm>


More information about the hotspot-gc-dev mailing list