Request for review (S): 7113021 G1: automatically enable young gen size auto-tuning when -Xms==-Xmx
john.cuthbertson at oracle.com
Wed Dec 21 22:08:31 UTC 2011
On 12/21/11 14:07, Bengt Rutisson wrote:
>> Can you rename calculate_default_min_size() to be something like
>> "calculate_default_min_region_num()"? Similarly for
>> calculate_default_max_size(). They return a number of regions rather
>> than a size in bytes.
> Good point. How about calculate_default_min_length() since the
> variables we set are called *_length and I think we often refer to the
> young gen "size" as the length?
That's fine with me.
> Here is an updated webrev:
> Thanks again for the review!
Looks good. Ship it.
More information about the hotspot-gc-dev