RFR(XS): 7193946: Move warnings associated with UseMemSetInBOT flag
ysr1729 at gmail.com
Fri Sep 14 20:45:48 UTC 2012
Looks good to me too; and I'd agree with Bengt that the code really belongs
under "consistency checking" rather than under "parsing".
On Fri, Sep 14, 2012 at 5:31 PM, John Cuthbertson <
john.cuthbertson at oracle.com> wrote:
> Hi Bengt,
> Thanks for the review. I too went back and forth about where to put the
> check. I'm not sure there is a clear division but I'll see which location
> looks a bitter 'fit'.
> On 09/13/12 23:39, Bengt Rutisson wrote:
>> Hi John,
>> Thanks for fixing this!
>> It looks good to me. I'm not really sure about how the work in
>> arguments.cpp is supposed to be divided. You added the new check to
>> Arguments::parse() but I guess it would be possible to put the code into
>> Snippet Arguments::check_vm_args_**consistency() instead. It looks to me
>> like it might fit better there, but I am fine with leaving it in
>> Arguments::parse() as well. Just glad to get rid of the duplicated code.
>> On 2012-09-13 18:58, John Cuthbertson wrote:
>>> Hi Everyone,
>>> Can I have a couple of volunteers review the changes for this CR? They
>>> are fairly small. The webrev can be found at:
>>> In the review comments for the fix for 7192128, Bengt suggested to move
>>> the individual warnings from concurrentMarkSweepGeneration.**cpp and
>>> g1Collectedheap.cpp and place a single warning in a common piece of code.
>>> These changes address that review comment. The suggested location
>>> (vm_version_sparc.cpp) was unsuitable as the routine which would be the
>>> natural choice is called twice and the warning would be issued twice. A
>>> better place is when we check the other GC flags for consistency in
>>> * command line testing
>>> * GC basher and GCOld on sun4v with and without UseMemSetInBOT set
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the hotspot-gc-dev