RFR(S): 8010738: G1: Output for full GCs with +PrintGCDetails should contain perm gen size/meta data change info

John Cuthbertson john.cuthbertson at oracle.com
Wed May 8 23:47:15 UTC 2013

Hi Jon,

On 5/8/2013 10:15 AM, Jon Masamitsu wrote:
> On 5/7/2013 8:40 PM, Bengt Rutisson wrote:
>> What do you think about renaming _heap_bytes_before_gc to 
>> _heap_used_before_gc? Seems more consistent with the other variable 
>> names such as _heap_capacity_before_gc.
>> Similarly, what do you think about renaming the local varialbles 
>> *_byte_* to *_used_* in 
>> G1CollectorPolicy::print_detailed_heap_transition()?
> Sorry, but removing the "bytes" from the name will make me wonder
> about the units.  When we have a rule that says "all quantities are in
> bytes unless otherwise indicated by the name of the variable", I
> will be happy with such a renaming.

How about a compromise - *_used_bytes_*?


More information about the hotspot-gc-dev mailing list