RFR: 8048269: Add flag to turn off class unloading after G1 concurrent mark

Stefan Karlsson stefan.karlsson at oracle.com
Fri Jul 11 05:44:00 UTC 2014

On 2014-07-11 01:11, Jon Masamitsu wrote:
> Could we use a more GC generic name for the flag such as
> GCClassUnloadingEnabled instead of a G1 specific name and
> at some point move CMS to use the GC generic name?

Yes, me and Bengt was talking about that, but IMHO we couldn't come up 
with a flag with a reasonably short and to-the-point flag name. I don't 
like the GCClassUnloadingEnabled since it could be mistaken to mean turn 
of class unloading entirely, which isn't what the flag is supposed to do.

Some of the names we thought about:
     This sounds we're doing the class unloading concurrently, which 
isn't the case.




Any more suggestions?


> Jon
> On 07/10/2014 08:19 AM, Stefan Karlsson wrote:
>> Hi all,
>> Please, review this patch to add code and a flag to turn off class 
>> unloading after G1 concurrent mark.
>> http://cr.openjdk.java.net/~stefank/8048269/webrev.00/
>> https://bugs.openjdk.java.net/browse/JDK-8048269
>> thanks,
>> StefanK

More information about the hotspot-gc-dev mailing list