RFR: 8047821: G1 Does not use the save_marks functionality as intended
mikael.gerdin at oracle.com
Mon Jun 23 14:26:00 UTC 2014
As part of a larger effort to detach G1's HeapRegion from ContiguousSpace
and as a general cleanup we should rename the save_marks and set_saved_marks
methods on HeapRegion. They are not used with oops_since_saved_marks_iterate
and cause more confusion than anything.
This change is part of a set of 4 changes: 8047818, 8047819, 8047820, 8047821
which are needed to refactor the HeapRegion class and its superclasses
in order to simplify the G1 class unloading change which is coming.
More information about the hotspot-gc-dev