RFR (M): 8060697: Improve G1 Heap Growth Heuristics

Tom Benson tom.benson at oracle.com
Tue Dec 8 01:35:27 UTC 2015

Hi Kim,
Yes, that's it exactly.  I'm not bothered by it, but am open to 
suggestions if someone feels strongly.

On 12/7/2015 7:30 PM, Kim Barrett wrote:
> On Dec 3, 2015, at 11:40 AM, Tom Benson <tom.benson at oracle.com> wrote:
>> Updated webrevs (including the suggestions from Kim and Jon) are in:
>>    http://cr.openjdk.java.net/~tbenson/8060697/webrev.01.vs.00/    - incremental
>> http://cr.openjdk.java.net/~tbenson/8060697/webrev.01/ - full
> I'd previously overlooked the removal of the const qualifier from
> G1CollectorPolicy::expansion_amount. This was done to permit some
> member variables to be updated to accumulate additional information
> (specifically, the fields that are reset by the new
> clear_ratio_check_data). But the function name "expansion_amount"
> looks to me like an accessor or compute function, and not something
> that modifies the policy object.
> I don't have a good alternative (either structure or naming) to offer
> right now, but maybe you or someone else might think of something.  Or
> maybe I'm the only one (somewhat) bothered by this.

More information about the hotspot-gc-dev mailing list