RFR: JDK-8068589: GCCause should distinguish jcmd GC.run from System.gc()
kirk at kodewerk.com
Tue Jan 27 19:57:08 UTC 2015
On Jan 27, 2015, at 8:37 PM, Staffan Larsen <staffan.larsen at oracle.com> wrote:
>> On 27 jan 2015, at 18:00, Kirk Pepperdine <kirk at kodewerk.com> wrote:
>> On Jan 27, 2015, at 1:22 PM, Yasumasa Suenaga <yasuenag at gmail.com> wrote:
>>> Hi Staffan,
>>> Thank you for your comments.
>>> I've uploaded new webrev:
>>> I changed as below:
>>> - GCCause::_jcmd_gc_run -> GCCause::_dcmd_gc_run
>>> - GCCause string: "jcmd GC.run" -> "GC.run DCmd”
>> Can I suggest a shortened GCCause string to “DiagCmd”. At the very least I’d prefer to not have the “.” in the string.
> I would have suggested “GC.run Diagnostic Command”, or “Diagnostic Command: GC.run”. I don’t know what problems a ‘.’ causes. “System.gc()” already has one.
Indeed it does and it and it has () and really wished neither were there. But unfortunately I missed the change from System to System.gc(). It complicates regex which may not seem like a big deal until you add in the entire GC log picture from 1.6.0 ’til 1.9.0 across all collectors and the possible flag combinations... it only adds (needlessly) to the mess.
Anyway, it’s a record in a GC log so I don’t see the value of GC.run. Certainly “DiagCmd" or even "Diagnostic Command” seems sufficient given the context.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 496 bytes
Desc: Message signed with OpenPGP using GPGMail
More information about the hotspot-gc-dev