RFR (XXS): 8136680: Enable adaptive IHOP by default

Jon Masamitsu jon.masamitsu at oracle.com
Mon Nov 30 17:35:25 UTC 2015

On 11/26/2015 02:20 AM, Thomas Schatzl wrote:
> Hi Jon,
>    thanks for the review.
> On Tue, 2015-11-24 at 10:33 -0800, Jon Masamitsu wrote:
>> Thomas, Looks good.
>> 36 product(bool, G1UseAdaptiveIHOP, true, \
>>     37           "Adaptively adjust InitiatingHeapOccupancyPercent from the "      \
>> 38 "initial value. The policy tries to start marking as late as " \
>> 39 "possible.")
>> Let me suggest an alternate comment though.
>> "Dynamically adjust the initiating heap occupancy from the  initial
>> value of
>> InitiatingHeapOccupancyPercent.  The policy attempts to start marking in
>> time based on application behavior."
> Much better. Updated webrev at
> http://cr.openjdk.java.net/~tschatzl/8136680/webrev.1/


>> Do we need G1 in the name of the flag?  Would UseAdaptiveIHOP be
>> sufficient?   Or maybe UseDynamicIHOP?  Or  (I write this with some
>> trepidation) would the flag be better named
>> UseAdaptiveInitiatingHeapOccupancy
>> or UseDynamicInitiatingHeapOccupancy?
> As for Adaptive vs. Dynamic, I think Adaptive captures the spirit of the
> change better. Also I have not seen other similar flags using Dynamic,
> but Adaptive.

"Adaptive" it is then.

> As for adding "G1" in front of the flag or not, not sure. CMS also has
> its flags prepended with "CMS". Maybe other people have stronger
> opinions about this, I would be okay with either.

I thought about it because "InitiatingHeapOccupancyPercent" does
have the "G1".  But if no one else speaks up on this, leave the "G1"
in the name.

> I also thought about using the long forms, but I think they are too
> long :)

Ok.  I can live with it.



>> I'm asking the question now because I don't want to ask it the next time
>> we do a cleanup of flag names.  I can live with any of the above.
> Thanks,
>    Thomas

More information about the hotspot-gc-dev mailing list