RFR (S) JDK-8139651 JDK-8139651, ConcurrentG1Refine uses ints for many of its members that should be unsigned types
kim.barrett at oracle.com
Thu Feb 18 19:45:03 UTC 2016
> On Feb 18, 2016, at 1:25 PM, Tom Benson <tom.benson at oracle.com> wrote:
>> I think some of these numbers are semantically not so much "sizes" as
>> "counts", and wonder if such might be better typed as uint or uintx
>> rather than size_t.
> I think the ones that are "counts" are "lengths" of queues (or thresholds/limits of lengths), and thus sort-of-kind-of "sizes". 8^) I agree, it's debatable.
Yes, I waffled back and forth about that. I think you’ve convinced me that size_t is ok for these.
More information about the hotspot-gc-dev