RFR (M): 8034842: Parallelize the Free CSet phase in G1
thomas.schatzl at oracle.com
Wed Jul 13 08:10:47 UTC 2016
On Mon, 2016-07-11 at 08:57 -0700, Jon Masamitsu wrote:
> Looks correct as is. Just some comments about readability
> for your considerations.
there is a new webrev + diff at
In addition to your comments I incorporated suggestions by Erik:
- tried to minimize some assert before recording survivor words.
- renamed work_item_t to WorkItem to conform to naming conventions.
- removed the trick with using the sign bit of a double as a boolean to
know whether it had been changed for better readability.
Thanks a lot,
More information about the hotspot-gc-dev