RFR: 8224663: Parallel GC: Use WorkGang (5: ScavengeRootsTask)
thomas.schatzl at oracle.com
Tue Aug 6 15:03:13 UTC 2019
On 06.08.19 10:17, Leo Korinth wrote:
> On 05/08/2019 23:51, Kim Barrett wrote:
>> In workgang nomenclature, scavenge_roots_task and steal_task are
>> perhaps misnamed. They aren't tasks, they are helper work functions.
>> Maybe they should be called scavenge_roots_work and steal_work?
> You are probably right.
>> I don't remember if there were similar possible naming issues
>> elsewhere in this cluster of changes. And you should verify the
>> naming convention with someone else before making any changes in
>> response to this comment.
> I have named all these "*_work" functions "*_task" consistently through
> all patches to reflect the old usage of the code :-(, I will rename them
> if Thomas agree, is that okay with you Thomas?
I am good with that suggestion.
More information about the hotspot-gc-dev