RFR: 8235757 : Rename SupportedGC to IncludedGC
per.liden at oracle.com
Wed Dec 11 11:36:11 UTC 2019
Looks good (and trivial)!
On 12/11/19 12:27 PM, Stefan Karlsson wrote:
> Hi all,
> Please review this trivial patch to rename SupportedGC (and associated
> macros and functions) to IncludedGC.
> I want to do this name change to disambiguate an upcoming addition to
> GCConfig::is_gc_supported, where built-in GCs doesn't mean that the GC
> is supported on the current platform.
> I'm using the name IncludedGC because it reflects our usage of
> INCLUDE_*GC macros and defines.
More information about the hotspot-gc-dev