RFR: 8219633: ZGC: Rename ZPageSizeMin to ZGranuleSize

Erik Österlund erik.osterlund at oracle.com
Mon Feb 25 14:00:50 UTC 2019

Hi Per,

Seems like this will break the SA. Otherwise it looks good.


On 2019-02-25 10:48, Per Liden wrote:
> The size of the unit of memory managed by ZGC is currently called 
> ZPageSizeMin. However, this constant is used in places where we're not 
> necessarily dealing with a ZPage, so calling it ZPageSizeMin isn't 
> quite right. Rename ZPageSizeMin to ZGranuleSize.
> Bug: https://bugs.openjdk.java.net/browse/JDK-8219633
> Webrev: http://cr.openjdk.java.net/~pliden/8219633/webrev.0
> /Per

More information about the hotspot-gc-dev mailing list