RFR(S) 8225813: Shenandoah: Obsolete ShenandoahSuspendibleWorkers flag, as suspendible workers are required

Roman Kennke rkennke at redhat.com
Sat Jun 15 19:35:21 UTC 2019


Can you give a little bit of explanation why workers need to be
suspended at safepoints for concurrent root processing?

Other than that, the patch looks good.

Roman

> Please review this patch that makes suspendible workers required,
> instead of optional, and obsoletes the corresponding flag.
> 
> Suspendible workers are required for concurrent root processing.
> 
> Bug: https://bugs.openjdk.java.net/browse/JDK-8225813
> Webrev: http://cr.openjdk.java.net/~zgu/JDK-8225813/webrev.00/index.html
> 
> Test:
>   hotspot_gc_shenandoah (fastdebug and release)
> 
> Thanks,
> 
> -Zhengyu

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://mail.openjdk.java.net/pipermail/hotspot-gc-dev/attachments/20190615/a98eb8be/signature.asc>


More information about the hotspot-gc-dev mailing list