RFR: 8231113: Adjust CollectedHeap::check_oop_location()

Per Liden per.liden at oracle.com
Tue Sep 17 13:02:32 UTC 2019

I propose we adjust and rename CollectedHeap::check_oop_location() into 
CollectedHeap::is_oop_location() that returns a bool, to better match 
its sibling CollectedHeap::is_oop() and how that is used.

Bug: https://bugs.openjdk.java.net/browse/JDK-8231113
Webrev: http://cr.openjdk.java.net/~pliden/8231113/webrev.0


More information about the hotspot-gc-dev mailing list