RFR: 8251837: Rename get_safepoint_workers to safepoint_workers

Stefan Karlsson stefan.karlsson at oracle.com
Fri Aug 14 14:53:05 UTC 2020


Hi all,

Please review this trivial rename to get rid of the get_ prefix in 
get_safepoint_workers.

https://cr.openjdk.java.net/~stefank/8251837/webrev.01/
https://bugs.openjdk.java.net/browse/JDK-8251837

We usually don't add get_ prefixes to our getters:

https://hg.openjdk.java.net/jdk/jdk/file/1b316786d245/doc/hotspot-style.md

"""
* Getter accessor names are noun phrases, with no "`get_`" noise
word. Boolean getters can also begin with "`is_`" or "`has_`".  Member
function for reading data members usually have the same name as the
data member, exclusive of the leading underscore.
"""

Thanks,
StefanK


More information about the hotspot-gc-dev mailing list