RFR (XXS): 8252086: G1: Remove g1_rs in G1CollectedHeap::initialize

Thomas Schatzl thomas.schatzl at oracle.com
Fri Aug 21 08:57:56 UTC 2020


Hi Stefan,

   thanks for your review.

Thomas

On 20.08.20 12:12, stefan.johansson at oracle.com wrote:
> Hi Thomas,
> 
> On 2020-08-20 12:06, Thomas Schatzl wrote:
>> Hi,
>>
>>    can I have reviews for this small change that removes an 
>> intermediate local variable from G1CollectedHeap::initialize?
>>
>> This makes it easier to follow that CollectedHeap::_reserved is the 
>> same as HeapRegionManager::reserved().
>>
>> CR:
>> https://bugs.openjdk.java.net/browse/JDK-8252086
>> Webrev:
>> http://cr.openjdk.java.net/~tschatzl/8252086/webrev/
> Looks great, thanks for cleaning up the code.
> 
> Cheers,
> Stefan
> 
>> Testing:
>> local compilation, local jtreg gc/g1 directory
>>
>> Thanks,
>>    Thomas



More information about the hotspot-gc-dev mailing list