RFR: 8249225 - Move definition of PADDING_ELEM_NUM
thomas.schatzl at oracle.com
Thu Jul 23 10:24:52 UTC 2020
On 21.07.20 03:41, Cesar Soares Lucas wrote:
> Bug: https://bugs.openjdk.java.net/browse/JDK-8249225
> Webrev: http://cr.openjdk.java.net/~adityam/cesar/8249225/
> Please review the above linked patch for the mentioned bug. It's a small change
> that moves the definition of "PADDING_ELEM_NUM" to the only file that uses it.
> I also took the chance of converting it from a "#define" directive into a "const"
> declaration - I can revert it back to a #define if you think it's better.
could the change please re-add the newline after array_length? It is
easier to read if generation of the constants is slightly offset from
the other code.
Looks good otherwise. I do not need a re-review for this change.
Do you need a sponsor?
More information about the hotspot-gc-dev