RFR (S): 8248221: G1: millis_since_last_gc updated at wrong time

Thomas Schatzl thomas.schatzl at oracle.com
Fri Jun 26 11:00:30 UTC 2020


Hi,

On 25.06.20 20:49, Kim Barrett wrote:
>> On Jun 25, 2020, at 4:04 AM, Thomas Schatzl <thomas.schatzl at oracle.com> wrote:
>>
>> CR:
>> https://bugs.openjdk.java.net/browse/JDK-8248221
>> Webrev:
>> http://cr.openjdk.java.net/~tschatzl/8248221/webrev/
>> Testing:
>> tier1-5 with 8243974 and 8165501, manual testing as described above.
> 
> ------------------------------------------------------------------------------
> src/hotspot/share/gc/g1/g1CollectedHeap.cpp
> 2067     _time_of_last_gc_ns = os::javaTimeNanos();
> 
> This variable seems really poorly named.
> 
> _time_for_millis_since_last_gc ?
> 
> Of course, millis_since_last_gc's name seems pretty poor too.
> 
> Maybe update those names as a followup.
> 
> ------------------------------------------------------------------------------
> 
> Other than that naming issue, looks good.
> 

   I totally agree that millis_since_last_gc is very much misnamed, but 
I would like to not redo the recent three changes in that area because 
of that. I will file a CR.

Thanks for your review,
   Thomas


More information about the hotspot-gc-dev mailing list