RFR: 8246044: ZGC: Rename ZDirector's max_capacity to soft_max_capacity

Per Liden per.liden at oracle.com
Thu May 28 09:31:46 UTC 2020


Thanks Stefan!

/Per

On 5/28/20 10:50 AM, Stefan Karlsson wrote:
> Looks good.
> 
> StefanK
> 
> On 2020-05-28 10:20, Per Liden wrote:
>> After JDK-8222182, ZDirector started to use the "soft max capacity" to 
>> guide its heuristics. However, a number of local variables are still 
>> called max_capacity. I propose we rename them soft_max_capacity for 
>> clarity.
>>
>> Bug: https://bugs.openjdk.java.net/browse/JDK-8246044
>> Webrev: http://cr.openjdk.java.net/~pliden/8246044/webrev.0
>>
>> /Per
> 


More information about the hotspot-gc-dev mailing list