RFR: 8246044: ZGC: Rename ZDirector's max_capacity to soft_max_capacity

Erik Österlund erik.osterlund at oracle.com
Fri May 29 09:26:30 UTC 2020


+1

/Erik

On 2020-05-28 10:20, Per Liden wrote:
> After JDK-8222182, ZDirector started to use the "soft max capacity" to 
> guide its heuristics. However, a number of local variables are still 
> called max_capacity. I propose we rename them soft_max_capacity for 
> clarity.
>
> Bug: https://bugs.openjdk.java.net/browse/JDK-8246044
> Webrev: http://cr.openjdk.java.net/~pliden/8246044/webrev.0
>
> /Per



More information about the hotspot-gc-dev mailing list