RFR: 8256484: ZGC: Rename ZRelocationSetSelector::register_garbage_page()

Per Liden pliden at openjdk.java.net
Tue Nov 17 17:17:14 UTC 2020


This came up in a review of a separate change. `ZRelocationSetSelector::register_garbage_page()` is a slightly misleading name, since "live pages" can also contain garbage. A better name is `ZRelocationSetSelector::register_empty_page()`. To keep the names consistent I propose that we also rename `_registered_pages` to `_live_pages`, to match better `ZRelocationSetSelector::register_live_page()`.

-------------

Commit messages:
 - 8256484: ZGC: Rename ZRelocationSetSelector::register_garbage_page()

Changes: https://git.openjdk.java.net/jdk/pull/1264/files
 Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=1264&range=00
  Issue: https://bugs.openjdk.java.net/browse/JDK-8256484
  Stats: 46 lines in 5 files changed: 0 ins; 0 del; 46 mod
  Patch: https://git.openjdk.java.net/jdk/pull/1264.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/1264/head:pull/1264

PR: https://git.openjdk.java.net/jdk/pull/1264


More information about the hotspot-gc-dev mailing list