Integrated: 8256484: ZGC: Rename ZRelocationSetSelector::register_garbage_page()

Per Liden pliden at openjdk.java.net
Tue Nov 17 20:51:05 UTC 2020


On Tue, 17 Nov 2020 17:11:47 GMT, Per Liden <pliden at openjdk.org> wrote:

> This came up in a review of a separate change. `ZRelocationSetSelector::register_garbage_page()` is a slightly misleading name, since "live pages" can also contain garbage. A better name is `ZRelocationSetSelector::register_empty_page()`. To keep the names consistent I propose that we also rename `_registered_pages` to `_live_pages`, to match better `ZRelocationSetSelector::register_live_page()`.

This pull request has now been integrated.

Changeset: f7517386
Author:    Per Liden <pliden at openjdk.org>
URL:       https://git.openjdk.java.net/jdk/commit/f7517386
Stats:     46 lines in 5 files changed: 0 ins; 0 del; 46 mod

8256484: ZGC: Rename ZRelocationSetSelector::register_garbage_page()

Reviewed-by: stefank, ayang

-------------

PR: https://git.openjdk.java.net/jdk/pull/1264


More information about the hotspot-gc-dev mailing list