RFR: 8193559: ugly DO_JAVA_THREADS macro should be replaced

Albert Mingkun Yang ayang at openjdk.java.net
Fri Jul 2 21:45:48 UTC 2021

On Fri, 2 Jul 2021 16:03:57 GMT, Daniel D. Daugherty <dcubed at openjdk.org> wrote:

> This is a simple rewrite of what is "Possibly the ugliest for loop the world has seen."
> Thanks to @stefank for the draft proposed fix. Thanks to @fisk for providing this
> piece of history that I'm finally getting around to cleaning up. While this macro has
> been with us for a long time, its time has passed...
> Tested with Mach5 Tier[1-3].

Marked as reviewed by ayang (Committer).


PR: https://git.openjdk.java.net/jdk/pull/4671

More information about the hotspot-gc-dev mailing list