RFR: 8193559: ugly DO_JAVA_THREADS macro should be replaced [v2]

Daniel D.Daugherty dcubed at openjdk.java.net
Sat Jul 3 03:40:12 UTC 2021

> This is a simple rewrite of what is "Possibly the ugliest for loop the world has seen."
> Thanks to @stefank for the draft proposed fix. Thanks to @fisk for providing this
> piece of history that I'm finally getting around to cleaning up. While this macro has
> been with us for a long time, its time has passed...
> Tested with Mach5 Tier[1-3].

Daniel D. Daugherty has updated the pull request incrementally with one additional commit since the last revision:

  kbarrett CR - delete unused _list member.


  - all: https://git.openjdk.java.net/jdk/pull/4671/files
  - new: https://git.openjdk.java.net/jdk/pull/4671/files/3f653c53..5ee49914

 - full: https://webrevs.openjdk.java.net/?repo=jdk&pr=4671&range=01
 - incr: https://webrevs.openjdk.java.net/?repo=jdk&pr=4671&range=00-01

  Stats: 2 lines in 1 file changed: 0 ins; 1 del; 1 mod
  Patch: https://git.openjdk.java.net/jdk/pull/4671.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/4671/head:pull/4671

PR: https://git.openjdk.java.net/jdk/pull/4671

More information about the hotspot-gc-dev mailing list