RFR: 8193559: ugly DO_JAVA_THREADS macro should be replaced [v2]

David Holmes dholmes at openjdk.java.net
Sun Jul 4 12:25:55 UTC 2021

On Sat, 3 Jul 2021 17:11:20 GMT, Kim Barrett <kbarrett at openjdk.org> wrote:

>> I can't find a way to fix that without adding back some of the crazy things
>> in the original macro.
> I wasn't expecting any change based on that comment, just pointing out that the code
> *is* contrary to the style guide, in a place where I think the guide should be changed.

I'm surprised that a declaration is even legal in that position - but then I should never be surprised at the crazy things C++ allows. :( I do think  it looks truly awful to have a declaration there. Surely we do not have to reduce this to being a single-line macro that emulates a for-loop? That said I can't make any sense out of the original macro so sure this is a less-ugly macro. But why does this have to be so obscure - aren't we just walking the current threads-list ??


PR: https://git.openjdk.java.net/jdk/pull/4671

More information about the hotspot-gc-dev mailing list