RFR: 8193559: ugly DO_JAVA_THREADS macro should be replaced [v2]
kbarrett at openjdk.java.net
Sun Jul 4 22:32:58 UTC 2021
On Sat, 3 Jul 2021 03:40:12 GMT, Daniel D. Daugherty <dcubed at openjdk.org> wrote:
>> This is a simple rewrite of what is "Possibly the ugliest for loop the world has seen."
>> Thanks to @stefank for the draft proposed fix. Thanks to @fisk for providing this
>> piece of history that I'm finally getting around to cleaning up. While this macro has
>> been with us for a long time, its time has passed...
>> Tested with Mach5 Tier[1-3].
> Daniel D. Daugherty has updated the pull request incrementally with one additional commit since the last revision:
> kbarrett CR - delete unused _list member.
Changes requested by kbarrett (Reviewer).
More information about the hotspot-gc-dev