RFR: 8270282: Semantically rename reference processing subphases

Kim Barrett kbarrett at openjdk.java.net
Mon Jul 12 22:40:54 UTC 2021


On Mon, 12 Jul 2021 14:17:53 GMT, Albert Mingkun Yang <ayang at openjdk.org> wrote:

>> src/hotspot/share/gc/shared/referenceProcessorPhaseTimes.hpp line 83:
>> 
>>> 81:   ~ReferenceProcessorPhaseTimes();
>>> 82: 
>>> 83:   WorkerDataArray<double>* SoftWeakFinalRefsPhase_worker_time_sec() const { return _SoftWeakFinalRefsPhase_worker_time_sec; }
>> 
>> This is a weird function name.  I understand why, but I'm not convinced.  We have process_soft_weak_final_refs and the like, for example.
>
> How about `soft_weak_final_refs_phase_worker_time_sec()`?

Yes, that's normal style.  It's quite a mouthful, but it's not like it gets written very often.  With that change, I think this PR looks good.

-------------

PR: https://git.openjdk.java.net/jdk/pull/4752


More information about the hotspot-gc-dev mailing list