RFR: 8270014: Add scoped objects for g1 young gc verification and young gc internal timing [v2]
iwalulya at openjdk.java.net
Wed Jul 14 08:29:31 UTC 2021
On Wed, 14 Jul 2021 07:44:57 GMT, Thomas Schatzl <tschatzl at openjdk.org> wrote:
>> Added comments. `gc_pause` is the whole pause, `collection` is about just the collection part (as defined by the inner scope of the `do_collection_pause_at_safepoint_helper`). Feel free to suggest better naming.
> Maybe something like `record_young_collection_work_start`; another question is whether we should keep the `note_` prefix for the pause or change it to `record_` as well as it seems quite common.
I suggest we change to record_
More information about the hotspot-gc-dev