RFR: 8193559: ugly DO_JAVA_THREADS macro should be replaced [v4]
kbarrett at openjdk.java.net
Fri Jul 30 04:36:30 UTC 2021
On Fri, 30 Jul 2021 00:00:56 GMT, Daniel D. Daugherty <dcubed at openjdk.org> wrote:
>> This is a simple rewrite of what is "Possibly the ugliest for loop the world has seen."
>> Thanks to @stefank for the draft proposed fix. Thanks to @fisk for providing this
>> piece of history that I'm finally getting around to cleaning up. While this macro has
>> been with us for a long time, its time has passed...
>> Tested with Mach5 Tier[1-3].
> Daniel D. Daugherty has updated the pull request incrementally with one additional commit since the last revision:
> 8193559.kbarrett.part1 - Kim's proposed rewrite using newer C++ features.
src/hotspot/share/runtime/threadSMR.inline.hpp line 53:
> 51: assert_not_singular();
> 52: assert_same_list(i);
> 53: return _thread_ptr != i._thread_ptr;
Better might be to have the entire body consist of `return operator==(i);`.
More information about the hotspot-gc-dev