RFR: 8193559: ugly DO_JAVA_THREADS macro should be replaced [v4]

Daniel D.Daugherty dcubed at openjdk.java.net
Fri Jul 30 19:29:29 UTC 2021

On Fri, 30 Jul 2021 19:09:02 GMT, Kim Barrett <kbarrett at openjdk.org> wrote:

>> I think what's there is more clear. If we switch to `return operator==(i)`,
>> then I think that will lead to some head scratching. Especially since it's
>> making me wonder right now...
> And _obviously_ I meant `return !operator==(i)`.  Need to keep that all-important one-character difference...

Thanks for the clarification. Now you see why I was scratching my head and
wondering what C++ voodoo you were doing now... :-)


PR: https://git.openjdk.java.net/jdk/pull/4671

More information about the hotspot-gc-dev mailing list