RFR: 8269077: TestSystemGC uses "require vm.gc.G1" for large pages subtest

Kim Barrett kbarrett at openjdk.java.net
Mon Jun 21 14:55:30 UTC 2021


On Mon, 21 Jun 2021 10:17:38 GMT, Stefan Karlsson <stefank at openjdk.org> wrote:

> The invocation that runs with large pages are guarded with `@require vm.gc.G1` and doesn't explicitly state that G1 should be used.
> 
> This means two things:
> 1) We are not running the large pages subtest when other GCs are specified
> 2) Under some circumstances another GC is ergonomically selected and we run the test with that GC even though the test was guarded by `@require vm.gc.G1`.
> 
> I propose that we move the subtest to its own run section, without any requirement about the used GC.

Looks good.

-------------

Marked as reviewed by kbarrett (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/4538


More information about the hotspot-gc-dev mailing list