Integrated: 8269077: TestSystemGC uses "require vm.gc.G1" for large pages subtest

Stefan Karlsson stefank at openjdk.java.net
Tue Jun 22 07:48:29 UTC 2021


On Mon, 21 Jun 2021 10:17:38 GMT, Stefan Karlsson <stefank at openjdk.org> wrote:

> The invocation that runs with large pages are guarded with `@require vm.gc.G1` and doesn't explicitly state that G1 should be used.
> 
> This means two things:
> 1) We are not running the large pages subtest when other GCs are specified
> 2) Under some circumstances another GC is ergonomically selected and we run the test with that GC even though the test was guarded by `@require vm.gc.G1`.
> 
> I propose that we move the subtest to its own run section, without any requirement about the used GC.

This pull request has now been integrated.

Changeset: 1a818154
Author:    Stefan Karlsson <stefank at openjdk.org>
URL:       https://git.openjdk.java.net/jdk/commit/1a818154cfe852a680070c5c07f2df33109e5b54
Stats:     9 lines in 1 file changed: 7 ins; 1 del; 1 mod

8269077: TestSystemGC uses "require vm.gc.G1" for large pages subtest

Reviewed-by: tschatzl, kbarrett

-------------

PR: https://git.openjdk.java.net/jdk/pull/4538


More information about the hotspot-gc-dev mailing list