RFR: 8269120: Build failure with GCC 6.3.0 after JDK-8017163

Aleksey Shipilev shade at openjdk.java.net
Tue Jun 22 09:59:25 UTC 2021


On Tue, 22 Jun 2021 09:52:21 GMT, Thomas Schatzl <tschatzl at openjdk.org> wrote:

> What platform is still on GCC 6.3.0? It has been released in December 21, 2016 and actually the whole release series is apparently "no longer supported" according to the GNU homepage ([link](https://gcc.gnu.org/gcc-6/)). I kind of understand supporting still supported compilers, but officially unsupported ones with the last release 3 years ago?

Debian 9 "stretch" ships with GCC 6.3.0 [1], and it is supported until 2022 [2]. Plenty of servers (including some of my CI nodes) run it.

 [1] https://packages.debian.org/search?keywords=gcc
 [2] https://wiki.debian.org/LTS

-------------

PR: https://git.openjdk.java.net/jdk/pull/4551


More information about the hotspot-gc-dev mailing list