RFR: 8269126: Rename G1AllowPreventiveGC option to G1UsePreventiveGC

Thomas Schatzl tschatzl at openjdk.java.net
Wed Jun 23 08:32:38 UTC 2021


Hi all,

  can I have reviews for this change that as the title suggest only changes the name of the `G1AllowPreventiveGC` option to `G1UsePreventiveGC` to better conform to other G1 options which all use `Use`.

Since this is a diagnostic flag, no further process is required.

Testing: tier1-5

Thanks,
  Thomas

-------------

Commit messages:
 - Initial commit - rename G1AllowPreventiveGC to G1UsePreventiveGC

Changes: https://git.openjdk.java.net/jdk/pull/4571/files
 Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=4571&range=00
  Issue: https://bugs.openjdk.java.net/browse/JDK-8269126
  Stats: 5 lines in 4 files changed: 0 ins; 0 del; 5 mod
  Patch: https://git.openjdk.java.net/jdk/pull/4571.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/4571/head:pull/4571

PR: https://git.openjdk.java.net/jdk/pull/4571


More information about the hotspot-gc-dev mailing list