[jdk17] RFR: 8269126: Rename G1AllowPreventiveGC option to G1UsePreventiveGC

Thomas Schatzl tschatzl at openjdk.java.net
Fri Jun 25 06:52:13 UTC 2021


Hi all,

can I have reviews for this change that as the title suggest only changes the name of the `G1AllowPreventiveGC` option to `G1UsePreventiveGC` to better conform to other G1 options which all use `Use` as prefix (jdk17 version).

Since this is a diagnostic flag, no further process is required.

Testing: tier1-5

-------------

Commit messages:
 - Initial commit - rename

Changes: https://git.openjdk.java.net/jdk17/pull/132/files
 Webrev: https://webrevs.openjdk.java.net/?repo=jdk17&pr=132&range=00
  Issue: https://bugs.openjdk.java.net/browse/JDK-8269126
  Stats: 4 lines in 3 files changed: 0 ins; 0 del; 4 mod
  Patch: https://git.openjdk.java.net/jdk17/pull/132.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk17 pull/132/head:pull/132

PR: https://git.openjdk.java.net/jdk17/pull/132


More information about the hotspot-gc-dev mailing list