[jdk17] RFR: 8269126: Rename G1AllowPreventiveGC option to G1UsePreventiveGC

Thomas Schatzl tschatzl at openjdk.java.net
Tue Jun 29 08:38:07 UTC 2021

On Fri, 25 Jun 2021 15:33:44 GMT, Kim Barrett <kbarrett at openjdk.org> wrote:

>> Hi all,
>> can I have reviews for this change that as the title suggest only changes the name of the `G1AllowPreventiveGC` option to `G1UsePreventiveGC` to better conform to other G1 options which all use `Use` as prefix (jdk17 version).
>> Since this is a diagnostic flag, no further process is required.
>> Testing: tier1-5
> Looks good.

Thanks @kimbarrett @walulyai for your reviews.


PR: https://git.openjdk.java.net/jdk17/pull/132

More information about the hotspot-gc-dev mailing list