RFR: 8269126: Rename G1AllowPreventiveGC option to G1UsePreventiveGC

Kim Barrett kbarrett at openjdk.java.net
Tue Jun 29 14:05:05 UTC 2021


On Wed, 23 Jun 2021 08:22:33 GMT, Thomas Schatzl <tschatzl at openjdk.org> wrote:

> Hi all,
> 
>   can I have reviews for this change that as the title suggest only changes the name of the `G1AllowPreventiveGC` option to `G1UsePreventiveGC` to better conform to other G1 options which all use `Use`.
> 
> Since this is a diagnostic flag, no further process is required.
> 
> Testing: tier1-5
> 
> Thanks,
>   Thomas

Looks good.

-------------

Marked as reviewed by kbarrett (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/4571


More information about the hotspot-gc-dev mailing list