RFR: 8276721: G1: Refine G1EvacFailureObjectsSet::iterate [v2]

Hamlin Li mli at openjdk.java.net
Wed Nov 10 01:30:08 UTC 2021


On Tue, 9 Nov 2021 09:31:30 GMT, Thomas Schatzl <tschatzl at openjdk.org> wrote:

>> I was thinking handle_iteration() will be not that surprising for users as iterate(), but seems it's not.
>> Sure, let me just rename it as process_and_drop.
>
>> I was thinking handle_iteration() will be not that surprising for users as iterate(), but seems it's not. Sure, let me just rename it as process_and_drop.
> 
> The main issue I have with the current change is that this is a changeset with 160 changed lines for the purpose of renaming two methods which are each called once. That seems completely off.

Thanks @tschatzl @albertnetymk for your reviews.

-------------

PR: https://git.openjdk.java.net/jdk/pull/6303


More information about the hotspot-gc-dev mailing list