RFR: 8276093: Improve naming in closures to iterate over card sets [v2]

Thomas Schatzl tschatzl at openjdk.java.net
Wed Nov 17 20:34:22 UTC 2021

> Hi all,
>   can I have reviews for this renaming change that tries to change naming for some remembered set closures to include `Closure` instead of `Iterator` in their names. Additionally I removed two or so `G1` prefixes for nested classes. Hopefully this improves the situation a bit, although it's still a mess of nested closures.
> Testing: local compilation, gha
> Thanks,
>   Thomas

Thomas Schatzl has updated the pull request incrementally with one additional commit since the last revision:

  parameter names


  - all: https://git.openjdk.java.net/jdk/pull/6430/files
  - new: https://git.openjdk.java.net/jdk/pull/6430/files/455488f8..de89746f

 - full: https://webrevs.openjdk.java.net/?repo=jdk&pr=6430&range=01
 - incr: https://webrevs.openjdk.java.net/?repo=jdk&pr=6430&range=00-01

  Stats: 39 lines in 4 files changed: 0 ins; 0 del; 39 mod
  Patch: https://git.openjdk.java.net/jdk/pull/6430.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/6430/head:pull/6430

PR: https://git.openjdk.java.net/jdk/pull/6430

More information about the hotspot-gc-dev mailing list