Re: 答复: 答复: Discussion about unifying the wording buffer/node/element in G1, especially classes using G1SegmentedArray and related classes

Thomas Schatzl thomas.schatzl at oracle.com
Thu Nov 18 09:46:14 UTC 2021


Hi,

On 18.11.21 09:52, lihuaming (A) wrote:
> 
>> Another option to "buffer" for the ???? could be "segment".
> 
> "segment" is good as well, IMO.
> 
> I see, thanks for clarification.
> 
> How about following naming relationship?
> 	segmented array (1) -- segment (N) -- slot (M) -- element (1)
> 

fine with me.

Thomas


More information about the hotspot-gc-dev mailing list