RFR: 8276093: Improve naming in closures to iterate over card sets [v2]

Albert Mingkun Yang ayang at openjdk.java.net
Thu Nov 18 14:32:51 UTC 2021

On Wed, 17 Nov 2021 20:34:22 GMT, Thomas Schatzl <tschatzl at openjdk.org> wrote:

>> Hi all,
>>   can I have reviews for this renaming change that tries to change naming for some remembered set closures to include `Closure` instead of `Iterator` in their names. Additionally I removed two or so `G1` prefixes for nested classes. Hopefully this improves the situation a bit, although it's still a mess of nested closures.
>> Testing: local compilation, gha
>> Thanks,
>>   Thomas
> Thomas Schatzl has updated the pull request incrementally with one additional commit since the last revision:
>   parameter names

Marked as reviewed by ayang (Reviewer).


PR: https://git.openjdk.java.net/jdk/pull/6430

More information about the hotspot-gc-dev mailing list