RFR: 8277428: G1: Move G1STWIsAliveClosure::do_object_b definition back to g1CollectedHeap.cpp

Thomas Schatzl tschatzl at openjdk.java.net
Fri Nov 19 10:36:37 UTC 2021

On Fri, 19 Nov 2021 03:29:04 GMT, Hamlin Li <mli at openjdk.org> wrote:

> This is a trivial patch to move G1STWIsAliveClosure::do_object_b definition to the right file g1CollectedHeap.cpp.

Without checking performance, I think the definition should be moved to `g1CollectedHeap.inline.hpp`, not the .cpp file (and includes fixed up).

It's used on every reference for a few operations.


Changes requested by tschatzl (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/6470

More information about the hotspot-gc-dev mailing list