RFR: 8277789: G1: G1CardSetConfiguration prefixes num_ and max_ used interchangeably

Thomas Schatzl tschatzl at openjdk.java.net
Fri Nov 26 15:22:03 UTC 2021

On Thu, 25 Nov 2021 20:30:51 GMT, Ivan Walulya <iwalulya at openjdk.org> wrote:

> Hi all,
> Please review this small refactoring to consistently use prefix `max_` for variable names where the variable represents a limit in G1CardSetConfiguration.
> Thanks

Lgtm apart from that small proposed comment update.

src/hotspot/share/gc/g1/g1CardSet.hpp line 97:

> 95: 
> 96:   // Array of Cards configuration
> 97:   // Number of cards in "Array of Cards" set; 0 to disable.

Maybe add a "Maximum" here too.


Marked as reviewed by tschatzl (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/6567

More information about the hotspot-gc-dev mailing list